cancel
Showing results for 
Search instead for 
Did you mean: 

Data Center Fabric Sample Implementation Configuration

Data Center Fabric Sample Implementation Configuration

Sazon
New Contributor III

Hi Sirs,

 

Please help. Can you share a sample configuration for data center fabric? 

I have 2 units VDX8770 (H.A. via VRRP)

and 2 units of VDX6740 (connecting the application servers)

this is a new network. Just an easy set up and configurations will do. Thanks

 

44793543350e4db38adab4465616e9ec_dc1c0072-e155-40cd-b5c1-c4d5433801ec.png

 

 

Regards,

 

Sazon

 

 

 

 

1 ACCEPTED SOLUTION

Michael_Morey
Extreme Employee

Sazon,

 

I will assume you have your 8770s and 6740 in a single fabric and the fabric is operational, as this is what I typically see.

 

Globally you will want to configure the VLANs in order to allow all 4 devices to use them:

interface vlan 10
interface vlan 20

Then you would configure your Agg Switches (6740) interfaces appropriately as “Access” for untagged or “Trunk” for tagged:

Access:

interface TenGigabitEthernet 1/0/1
 switchport
 switchport mode access
 switchport access vlan 10
 spanning-tree shutdown
 fabric isl enable
 fabric trunk enable
 no shutdown

Trunk:

interface TenGigabitEthernet 1/0/1
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 10
 switchport trunk tag native-vlan
 spanning-tree shutdown
 fabric isl enable
 fabric trunk enable
 no shutdown
  • You can allow multiple tagged VLANs per port by specifying them in the “switchport trunk allowed vlan add” command

Traffic should be able to ingress into your fabric in order to reach the 8770/Core devices which will be setup with the L3 interfaces:

On each Core device you will need to enable VRRP in the RB context:

conf t
rb 1
protocol vrrp
rb 2
protocol vrrp

Then each RB will have a VE configured:

conf t
rb 1
int ve 10
ip address 192.168.10.2/24
vrrp-group 10
virtual-ip 192.168.10.1
enable

int ve 20
ip address 192.168.20.2/24
vrrp-group 20
virtual-ip 192.168.20.1
enable


rb 2

int ve 10
ip address 192.168.10.3/24
vrrp-group 10
virtual-ip 192.168.10.1
enable

int ve 20
ip address 192.168.20.3/24
vrrp-group 20
virtual-ip 192.168.20.1
enable

Lastly you would need to configure your upstream interfaces to your FW, I would expect as a trunk as well as a port channel (LACP Dynamic LAG) as your diagram shows 2 links going to the same device

interface Port-channel 1
vlag ignore-split
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown

interface TenGigabitEthernet 1/0/31
channel-group 1 mode active type standard
fabric isl enable
fabric trunk enable
lacp timeout long
no shutdown

interface TenGigabitEthernet 2/0/31
channel-group 1 mode active type standard
fabric isl enable
fabric trunk enable
lacp timeout long
no shutdown
  • As I described above, you can allow all as I have done here or limit this to just 10 and 20
interface Port-channel 1
vlag ignore-split
switchport
switchport mode trunk
switchport trunk allowed vlan add 10,20
switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown

 

For more information, please visit our Configuration Guides website

 

 

Michael Morey
Principal Technical Support Engineer
Extreme Networks

View solution in original post

2 REPLIES 2

Sazon
New Contributor III

Hi Michael,

 

Thanks a lot. This helps us to configure our devices.

 

Regards,

Sazon

Michael_Morey
Extreme Employee

Sazon,

 

I will assume you have your 8770s and 6740 in a single fabric and the fabric is operational, as this is what I typically see.

 

Globally you will want to configure the VLANs in order to allow all 4 devices to use them:

interface vlan 10
interface vlan 20

Then you would configure your Agg Switches (6740) interfaces appropriately as “Access” for untagged or “Trunk” for tagged:

Access:

interface TenGigabitEthernet 1/0/1
 switchport
 switchport mode access
 switchport access vlan 10
 spanning-tree shutdown
 fabric isl enable
 fabric trunk enable
 no shutdown

Trunk:

interface TenGigabitEthernet 1/0/1
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 10
 switchport trunk tag native-vlan
 spanning-tree shutdown
 fabric isl enable
 fabric trunk enable
 no shutdown
  • You can allow multiple tagged VLANs per port by specifying them in the “switchport trunk allowed vlan add” command

Traffic should be able to ingress into your fabric in order to reach the 8770/Core devices which will be setup with the L3 interfaces:

On each Core device you will need to enable VRRP in the RB context:

conf t
rb 1
protocol vrrp
rb 2
protocol vrrp

Then each RB will have a VE configured:

conf t
rb 1
int ve 10
ip address 192.168.10.2/24
vrrp-group 10
virtual-ip 192.168.10.1
enable

int ve 20
ip address 192.168.20.2/24
vrrp-group 20
virtual-ip 192.168.20.1
enable


rb 2

int ve 10
ip address 192.168.10.3/24
vrrp-group 10
virtual-ip 192.168.10.1
enable

int ve 20
ip address 192.168.20.3/24
vrrp-group 20
virtual-ip 192.168.20.1
enable

Lastly you would need to configure your upstream interfaces to your FW, I would expect as a trunk as well as a port channel (LACP Dynamic LAG) as your diagram shows 2 links going to the same device

interface Port-channel 1
vlag ignore-split
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown

interface TenGigabitEthernet 1/0/31
channel-group 1 mode active type standard
fabric isl enable
fabric trunk enable
lacp timeout long
no shutdown

interface TenGigabitEthernet 2/0/31
channel-group 1 mode active type standard
fabric isl enable
fabric trunk enable
lacp timeout long
no shutdown
  • As I described above, you can allow all as I have done here or limit this to just 10 and 20
interface Port-channel 1
vlag ignore-split
switchport
switchport mode trunk
switchport trunk allowed vlan add 10,20
switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown

 

For more information, please visit our Configuration Guides website

 

 

Michael Morey
Principal Technical Support Engineer
Extreme Networks
GTM-P2G8KFN