07-17-2024 06:00 AM - edited 07-18-2024 06:33 AM
Hello everyone, I am trying to figure out what I am doing wrong on a VDX 6740T switch. I am trying to basically set up a port for use as a point to direct connect to my laptop which is running a TFTP server. I set up the port with an IP of 192.168.0.3 and on the rbridge-id 1 I have the following config
rbridge-id 1
switch-attributes chassis-name VDX6740T
switch-attributes host-name sw0
vrf mgmt-vrf
address-family ipv4 unicast
ip route 0.0.0.0/0 192.168.0.2
Do I need to make the connection port a member of the rbridge? I am use to Cisco devices where a simple set up of an IP and default gateway is usually enough to make this work but not sure what is causing the issue with this setup currently.
Solved! Go to Solution.
07-18-2024 07:18 AM
On the VDX there are two VRFs by default; mgmt-vrf and default-vrf
The management interface itself is automatically within the mgmt-vrf, with the config "vrf forwarding mgmt-vrf" which is where you have your default route configured.
Your VE 10 with "ip address 192.168.0.3/24" has no vrf configured so therefore it is in the default-vrf.
Try adding "vrf forwarding mgmt-vrf" and then reapplying the IP address to VE 10 and see if you are successful.
Most commands use the default-vrf, including ping. If you want to ping your own Management IP, use the command:
"ping 172.16.200.2 vrf mgmt-vrf"
Hope that helps,
08-01-2024 06:18 AM
The FWDL command simply needs to be pointed to the directory containing all those SWBD folders.
You also used "\nos7.4.2.1j" which is not valid. I would remove the backslash and use the correct folder name: "nos7.4.1j"
08-01-2024 06:43 AM - edited 08-01-2024 06:52 AM
I get a "cannot access the server. Please check whether the server name of IP address is valid. " if I omit the \ in front of the nos7.4.1j.
07-18-2024 06:21 AM - edited 07-18-2024 06:36 AM
Right now I am able to ping from my laptop over to the Management interface IP but not to the VLAN however I cannot ping from the switch to my laptop.
Here is the updated rbridge config
rbridge-id 1
ip route 0.0.0.0/0 172.16.200.2
ip route 192.168.0.0/24 tengigabitethernet 1/0/1
switch-attributes chassis-name VDX6740T
switch-attributes host-name sw0
vrf mgmt-vrf
address-family ipv4 unicast
ip route 0.0.0.0/0 192.168.0.2
Here are the other configs for the interfaces I tried to use for this.
interface Ve 10
ip proxy-arp
ip address 192.168.0.3/24
no shutdown
!
interface Ve 100
ip proxy-arp
ip address 172.16.200.1/24
no shutdown
!
!
interface Management 1/0
no tcp burstrate
ip icmp echo-reply
no ip address dhcp
ip address 172.16.200.2/24
ipv6 icmpv6 echo-reply
no ipv6 address autoconfig
no ipv6 address dhcp
vrf forwarding mgmt-vrf
no shutdown
Evidently I am not able to even ping the management interface from the switch.
sw0# ping 172.16.200.2
Type Control-c to abort
PING 172.16.200.2 (172.16.200.2): 56 data bytes
ping: sendto: Network is unreachable
ping: sendto: Network is unreachable
ping: sendto: Network is unreachable
ping: sendto: Network is unreachable
ping: sendto: Network is unreachable
--- 172.16.200.2 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss