Showing results for 
Search instead for 
Did you mean: 

Internal error when self-registering on CWP

Internal error when self-registering on CWP

New Contributor II


We have 2x SSID; one (Company-Registration) with the possibility to self register and recieve a PPSK by mail/SMS which you then can use to authenticate with SSID number 2 (Company-GUEST).

This has been working for us without a problem for 2-3 years. A couple of days ago guests started getting "Internal Server Error" after filling out their user info and clicking Register. They only get this message and no PPSK is sendt by mail/sms. 

When i try to send mail/sms manually to already registered users, they recieve the mail/sms no problem.

This happened without any configuration changes on our ExtremeCloud IQ or Aerohive AP130 devices. 

I have tried checking logs but i cant find anything useful, I have also tried firmware upgrading the AP's to, Resetting IDM Client Certificate etc. I have tried my best googling this, but cant find anyone who has encountered this problem before. 

Does anyone have any tips/pointers to what could resolve this issue? Thank you very much in advance. 


New Contributor II

Update as of 12.04.23. 
This has now been fixed in the newest XIQ release. 

View solution in original post


New Contributor II

Hello and thank you for the replies! 

I have been in touch with Extreme technical support, and they have onboarded an AP on our controller to recreate the error. 
They were successful in recreating the error and have escalated the issue to the engineering department.

Currently awaiting a response, I will update the post as soon as i know more if anyone else runs into the same issues.