12-21-2020 02:17 PM
I have a Cisco 3750x 2 switch stack on the second floor of one of our offices and we leased a small suite in the 1st floor of this building for training purposes. We had the cabling vendor run mm fiber between floor 1 and 2. For a few months the 1st floor was connected by 2 x 1 gbps fiber connections to the second floor using a Cisco 3650 switch. Two WAN connections come into the second floor cisco switch stack and use OSPF to get back to HQ. The EXOS switch on the 1st floor is just an access switch extension off of the 2nd floor. The config looks like this:
interface Port-channel1
description Trunk to 1566 2nd Floor
switchport trunk allowed vlan 1,172
switchport trunk encapsulation dot1q
switchport mode trunk
ip arp inspection trust
spanning-tree bpdufilter enable
ip dhcp snooping trust
!
interface GigabitEthernet1/1
description uplink to 1566 Fl2 Switch 1 Gi1/1/4
switchport trunk allowed vlan 1,172
switchport trunk encapsulation dot1q
switchport mode trunk
ip arp inspection trust
mls qos trust dscp
spanning-tree portfast edge
spanning-tree bpdufilter enable
channel-group 1 mode active
ip dhcp snooping trust
!
interface GigabitEthernet1/2
description uplink to 1566 Fl2 Switch 2 Gi1/1/4
switchport trunk allowed vlan 1,172
switchport trunk encapsulation dot1q
switchport mode trunk
ip arp inspection trust
mls qos trust dscp
spanning-tree portfast edge
spanning-tree bpdufilter enable
channel-group 1 mode active
ip dhcp snooping trust
!
Now that switch although it works, its quite a number of years old, so we are replacing it with a 5520-24W-EXOS running EXOS 31.1.1.3. I put the 4 port NIM in the right side of this switch and in the first two ports I populated them with SFP 1 Gbps 850 nm devices. I attempted to swing the uplinks to these ports with this configuration, and the ports show a 1000mbps link, there is NO traffic flow on it, and the 2nd floor switch shows its port-channel down.
enable diffserv examination port 33
disable dot1p examination port 33
configure ports 33 description-string "Uplink to 1566 2nd Floor"
configure ports 33 auto off speed 1000 duplex full
enable sharing 33 grouping 33-34 algorithm address-based L3_L4 lacp
configure vlan Default add ports 1-33,35-36 untagged
configure vlan VOICE add ports 1-33,35-36 tagged
configure qosprofile QP3 minbw 0 maxbw 100 ports 33
configure qosprofile QP5 minbw 0 maxbw 100 ports 33
disable edp ports 33
enable cdp ports 33
configure vlan default delete ports 34
enable diffserv examination port 34
disable dot1p examination port 34
configure ports 34 description-string "Uplink to 1566 2nd Floor"
configure ports 34 auto off speed 1000 duplex full
enable sharing 33 grouping 33-34 algorithm address-based L3_L4 lacp
disable edp ports 34
enable cdp ports 34
Even with just ONE of the fibers connected, though the port lights and the sh port command indicates a link… traffic will not flow between the EXOS and Cisco switches.
I never had this issue with 450G2’s or 690X EXOS switches, but in those cases I am either connecting two or more ports to a server, or in case of our core, the 690X’s I am doing MLAGs from all other switches in the HQ building. The 5520 is a new switch for us, and we ordered 14 of them… this is our one 24 port (the rest are 48 and have plans to outfit other buildings with them). All switches were ordered with the 4 port expantion on the side since this model does not have those ports by default like the previous generation.
The 2nd floor of this building will eventually get its two Cisco 3750X stacked switches replaced with 2 5520’s stacked and the optics switched out for 10 gig on both ends. It’s one gig now because thats all the cisco supports.
Any idea’s what I did incorrectly? This is fairly simple, vlan 1 is data, vlan 172 is voip. Its a small installation.
sh port 33 vid
Untagged
Port /Tagged VID(s)
-------- -------- ------------------------------------------------------------
33 Untagged 1
Tagged 172
sh port 34 vid
Untagged
Port /Tagged VID(s)
-------- -------- ------------------------------------------------------------
34 Untagged 1
Tagged 172
sh sharing
Load Sharing Monitor
Config Current Agg Min Ld Share Ld Share Agg Link Link Up
Master Master Control Active Algorithm Flags Group Mbr State Transitions
================================================================================
33 LACP 1 L3_L4 A 33 - R 7
L3_L4 34 - R 7
================================================================================
12-21-2020 02:33 PM
STP is in use but should be disabled.
The counters are 0 probably because I just changed it.
Here is the config on the 2nd floor switch where this network originates in this building. I noticed bpdufilter is on the port channel but not the individual ports (is that wrong?). This links up no issues from Cisco to Cisco, just having difficulty from Cisco to EXOS.
interface Port-channel2
description Trunk to suite 112
switchport trunk allowed vlan 1,172
switchport trunk encapsulation dot1q
switchport mode trunk
ip arp inspection trust
spanning-tree bpdufilter enable
ip dhcp snooping trust
!
interface GigabitEthernet1/1/4
description Trunk to suite 112
switchport trunk allowed vlan 1,172
switchport trunk encapsulation dot1q
switchport mode trunk
ip arp inspection trust
mls qos trust dscp
spanning-tree portfast edge
channel-group 2 mode active
ip dhcp snooping trust
!
interface GigabitEthernet2/1/4
description Trunk to suite 112
switchport trunk allowed vlan 1,172
switchport trunk encapsulation dot1q
switchport mode trunk
ip arp inspection trust
mls qos trust dscp
spanning-tree portfast edge
channel-group 2 mode active
ip dhcp snooping trust
!
12-21-2020 02:29 PM
I noticed above the default vlan was removed from port 34. I disabled sharing 33 so it would let me correct that.
When I readded sharing I thought, what other options do I have. Would this work you think?
enable sharing 33 grouping 33-34 algorithm port-based lacp
instead of
enable sharing 33 grouping 33-34 algorithm address-based L3_L4 lacp
I’m only using the address-based because that’s what I’ve used (and proven to work) on all of our other EXOS switches.
12-21-2020 02:21 PM
Greetings,
Is STP in use?
Can you provide the output of “show lacp counters”?
Best regards
Stefan