12-21-2020 02:17 PM
I have a Cisco 3750x 2 switch stack on the second floor of one of our offices and we leased a small suite in the 1st floor of this building for training purposes. We had the cabling vendor run mm fiber between floor 1 and 2. For a few months the 1st floor was connected by 2 x 1 gbps fiber connections to the second floor using a Cisco 3650 switch. Two WAN connections come into the second floor cisco switch stack and use OSPF to get back to HQ. The EXOS switch on the 1st floor is just an access switch extension off of the 2nd floor. The config looks like this:
interface Port-channel1
description Trunk to 1566 2nd Floor
switchport trunk allowed vlan 1,172
switchport trunk encapsulation dot1q
switchport mode trunk
ip arp inspection trust
spanning-tree bpdufilter enable
ip dhcp snooping trust
!
interface GigabitEthernet1/1
description uplink to 1566 Fl2 Switch 1 Gi1/1/4
switchport trunk allowed vlan 1,172
switchport trunk encapsulation dot1q
switchport mode trunk
ip arp inspection trust
mls qos trust dscp
spanning-tree portfast edge
spanning-tree bpdufilter enable
channel-group 1 mode active
ip dhcp snooping trust
!
interface GigabitEthernet1/2
description uplink to 1566 Fl2 Switch 2 Gi1/1/4
switchport trunk allowed vlan 1,172
switchport trunk encapsulation dot1q
switchport mode trunk
ip arp inspection trust
mls qos trust dscp
spanning-tree portfast edge
spanning-tree bpdufilter enable
channel-group 1 mode active
ip dhcp snooping trust
!
Now that switch although it works, its quite a number of years old, so we are replacing it with a 5520-24W-EXOS running EXOS 31.1.1.3. I put the 4 port NIM in the right side of this switch and in the first two ports I populated them with SFP 1 Gbps 850 nm devices. I attempted to swing the uplinks to these ports with this configuration, and the ports show a 1000mbps link, there is NO traffic flow on it, and the 2nd floor switch shows its port-channel down.
enable diffserv examination port 33
disable dot1p examination port 33
configure ports 33 description-string "Uplink to 1566 2nd Floor"
configure ports 33 auto off speed 1000 duplex full
enable sharing 33 grouping 33-34 algorithm address-based L3_L4 lacp
configure vlan Default add ports 1-33,35-36 untagged
configure vlan VOICE add ports 1-33,35-36 tagged
configure qosprofile QP3 minbw 0 maxbw 100 ports 33
configure qosprofile QP5 minbw 0 maxbw 100 ports 33
disable edp ports 33
enable cdp ports 33
configure vlan default delete ports 34
enable diffserv examination port 34
disable dot1p examination port 34
configure ports 34 description-string "Uplink to 1566 2nd Floor"
configure ports 34 auto off speed 1000 duplex full
enable sharing 33 grouping 33-34 algorithm address-based L3_L4 lacp
disable edp ports 34
enable cdp ports 34
Even with just ONE of the fibers connected, though the port lights and the sh port command indicates a link… traffic will not flow between the EXOS and Cisco switches.
I never had this issue with 450G2’s or 690X EXOS switches, but in those cases I am either connecting two or more ports to a server, or in case of our core, the 690X’s I am doing MLAGs from all other switches in the HQ building. The 5520 is a new switch for us, and we ordered 14 of them… this is our one 24 port (the rest are 48 and have plans to outfit other buildings with them). All switches were ordered with the 4 port expantion on the side since this model does not have those ports by default like the previous generation.
The 2nd floor of this building will eventually get its two Cisco 3750X stacked switches replaced with 2 5520’s stacked and the optics switched out for 10 gig on both ends. It’s one gig now because thats all the cisco supports.
Any idea’s what I did incorrectly? This is fairly simple, vlan 1 is data, vlan 172 is voip. Its a small installation.
sh port 33 vid
Untagged
Port /Tagged VID(s)
-------- -------- ------------------------------------------------------------
33 Untagged 1
Tagged 172
sh port 34 vid
Untagged
Port /Tagged VID(s)
-------- -------- ------------------------------------------------------------
34 Untagged 1
Tagged 172
sh sharing
Load Sharing Monitor
Config Current Agg Min Ld Share Ld Share Agg Link Link Up
Master Master Control Active Algorithm Flags Group Mbr State Transitions
================================================================================
33 LACP 1 L3_L4 A 33 - R 7
L3_L4 34 - R 7
================================================================================
12-22-2020 08:58 PM
Hi Peter,
You are right but this is leading to an unbalanced link load.
The purpose of this algorithm is explicitly to achieve a load-balancing.
Using different algorithms at both ends has in this perspective no meaning.
It is true it will work and with the current bandwidths on the ports it is no so often that we get load-balancing issues.
Concerning your specific issue, if you want to be sure about the role of STP in your trouble, you can just disable it on the ports of the LAG (if there are no risks of loop). This will exclude (or not) STP investigations.
Mig
12-22-2020 08:35 PM
Hi Mig,
sorry, but this is wrong. You can have different algorithms at both ends.
For Example: I’ve lots of installations where EXOS is connected to EOS S-Series.
EXOS hast L3_L4 and S-Series round-robin.
12-22-2020 08:12 PM
Keith,
The load-balancing algorithm must be the same on both sides.
Could you try with a L2 load-balancing? It is the default one usually.
on the EXOS sideenable sharing 1:1 grouping 1:1,2:1 algorithm address-based L2 lacp
Mig
12-22-2020 07:42 PM
I’m not so familiar with Cisco. But afaik the STP Default on Cisco switches is PVST+ and on newer EXOS it is MSTP. You should check Spanning Tree stats
12-22-2020 05:57 PM
I put two new 5520’s in a stacked config in another office yesterday. I trunked two 1gbps copper ports from a Cisco 3750 switch stack to it for the transition period. IN Q1 we will transition devices to the EXOS platform, but the switch is online and up.
In this example it was easy…
on the EXOS side
enable sharing 1:1 grouping 1:1,2:1 algorithm address-based L3_L4 lacp
sh port 1:1,2:1 vid
Untagged
Port /Tagged VID(s)
-------- -------- ------------------------------------------------------------
1:1 Untagged 1
Tagged 172
2:1 Untagged 1
Tagged 172
On the Cisco Side
interface Port-channel2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,172
switchport mode trunk
ip arp inspection trust
spanning-tree bpdufilter enable
ip dhcp snooping trust
!
interface GigabitEthernet1/0/20
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,172
switchport mode trunk
ip arp inspection trust
ip access-group acl1 in
mls qos trust dscp
spanning-tree portfast
channel-group 2 mode active
ip dhcp snooping trust
!
interface GigabitEthernet1/0/44
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,172
switchport mode trunk
ip arp inspection trust
ip access-group acl1 in
mls qos trust dscp
spanning-tree portfast
channel-group 2 mode active
ip dhcp snooping trust
!
The only difference is the Extreme side is a two switch stack and I’m using copper cables because that's all I have. Eventually, once all the site is moved over to it, the Cisco switches will go away there.
Don’t know why it doesn’t work at our small office training site. Can you use 1 GIG fiber SFP’s in the right 4 port module? I mean if you sh port it does indicate its linked up…
I have 10 GIG fiber SFP+ in the switch stack going to a new vmware ESXi server that will be phased in as well. That works as long as its not in sharing mode (which I think I have to figure out the vmware side of things for that).