Showing results for 
Search instead for 
Did you mean: 

X440 IPForwarding Not Working as Expected

X440 IPForwarding Not Working as Expected

New Contributor
I currently have and X440 at one of my sites that I am creating a new VLAN to add in some additional IP's. I successfully did this at another site and it worked like a charm, but this one seems to not be cooperating. I have both rip and ipforwarding enabled on the Default and the new VLAN. The Default VLAN can ping the IP of the new VLAN and the new VLAN can ping the IP of the Default VLAN, but the new VLAN can't ping any devices on the old VLAN and the old VLAN can't ping any devices on the new VLAN.

I find it odd that the same config worked at another site, but doesn't on this one. The only difference from one site to another is the IP addresses used.

New Contributor

New Contributor
The problem was indeed, that my provider had put in a route to the wrong address on my switch (they used the IP of the new VLAN instead of the Default VLAN) and had incorrectly created a new interface on their router causing the traffic to not make it back.

Thanks to all of you who helped, you guys are the best!

New Contributor
I think the problem may lie with the router configs from my provider. After speaking with them a few minutes, I discovered they had placed the static route on their router to go to this first switch... but they also have an interface on their Cisco router that matches the subnet of my new VLAN and some extra routes.I have asked that they remove it since it was unnecessary.

I used GNS3 with a model of my site to confirm that if there is a router configured the way they have it, the packets won't make it back to where they need to go. As soon as I disabled that interface on the router, it let everything work normally.

I will confirm that this was the problem after they disable that extra interface and update this once they make their changes.

Extreme Employee
Hello Justin,

As you confirmed, if you execute the ping without specific the from option it's working, and if you specify the source ipaddress( the ping was unsuccessful. from this, it shows the peer device doesn't have any information about the network

Here you have configured the RIP protocol to advertised this networks, but did you check the rip neighbors status? if not please use the following command and check the neighbors status.
if there is an issue in the RIP neighborship, probably the peer device doesn't have the information about and it's led to the unreachable issue.

show rip interface VLAN This RIP specific statistics and configuration for a VLAN in detail.