cancel
Showing results for 
Search instead for 
Did you mean: 

Fabric Extend through wireless bridge but keep management IP addresses for bridge elements

Fabric Extend through wireless bridge but keep management IP addresses for bridge elements

dotelevenem
New Contributor

Hi,

We recently create L3 fabric extend logical interfaces to extend fabric through a wireless bridge following this article: How To: How to configure L3 Fabric Extend on VSP4K and VSP7/VSP8K. | Extreme Portal (site.com)   Logical interfaces were established but as we had to use brouter configuration on those ports we lost management thorugh IP for those wireless bridges as when you configure a brouter on that port, is not possible to make it member from port-mstprstp type of vlan. IP addresses are important are important as their monitoring system queries their wireless bridges to know they are still alive.

Script used to configure L3 Fabric Extend:

VSP1

ip vrf spboip vrfid 511
interface GigabitEthernet 1/2
no auto-sense enable
vrf spboip
brouter port 1/2 vlan 3999 subnet 192.168.234.2/24
exit
router vrf spboip
ip route 192.168.234.0 255.255.255.0 192.168.234.1 weight 10
exit

router isis
ip-tunnel-source-address 192.168.234.2 vrf spboip
exit
logical-intf isis 1 dest-ip 192.168.234.3 name to_VSP2
isis
isis spbm 1
isis spbm 1 l1-metric 2000
isis enable
exit

 

VSP2

ip vrf spboip vrfid 511
interface GigabitEthernet 1/2
no auto-sense enable
vrf spboip
brouter port 1/2 vlan 3999 subnet 192.168.234.3/24
exit
router vrf spboip
ip route 192.168.234.0 255.255.255.0 192.168.234.1 weight 10
exit

router isis
ip-tunnel-source-address 192.168.234.3 vrf spboip
exit
logical-intf isis 1 dest-ip 192.168.234.2 name to_VSP1
isis
isis spbm 1
isis spbm 1 l1-metric 2000
isis enable
exit

Is there a way we can recover management for the wireless gear?

 

 

1 ACCEPTED SOLUTION

gfriedl
Extreme Employee

Sure you can do that !

CmpB-L3:1(config-if)#% brouter port 1/10 vlan 3999 subnet 192.168.234.1/24
CmpB-L3:1(config-if)#% vlni 1/10
alias% show interfaces gigabitEthernet vlan 1/10
====================================================================================================
Port Vlans
====================================================================================================
PORT DISCARD DISCARD DEFAULT VLAN PORT UNTAG DYNAMIC UNTAG
NUM TAGGING TAGFRAM UNTAGFRAM VLANID IDS TYPE DEFVLAN VLANS VLANS
-----------------------------------------------------------------------------------------------------------
1/10 disable false false 0 0 normal disable P
----------------------------------------------------------------------------------------------------
--> port 1/10 is not member of any VLAN so far ...

CmpB-L3:1(config-if)#% sho brouter
Port Vlan Id
==== =======
1/10 3999

As long as "tagging" is disabled, you can't add VLANs ...
CmpB-L3:1(config-if)#% vlan members add 1 1/10
Brouter port cannot be added to VLAN.
Error: Operation not allowed
.. but now you change that ..
CmpB-L3:1(config)#% int g 1/10
CmpB-L3:1(config-if)#% encapsulation dot1q
CmpB-L3:1(config-if)#% vlan members add 1 1/10
CmpB-L3:1(config)#% vlni 1/10
alias% show interfaces gigabitEthernet vlan 1/10
====================================================================================================
Port Vlans
====================================================================================================
PORT DISCARD DISCARD DEFAULT VLAN PORT UNTAG DYNAMIC UNTAG
NUM TAGGING TAGFRAM UNTAGFRAM VLANID IDS TYPE DEFVLAN VLANS VLANS
-----------------------------------------------------------------------------------------------------------
1/10 enable false false 1 1 normal disable P
--------------------------------------------------------------------------------

--> and finally port is Brouter and member of VLAN 1 in this example.
Hope this helps!

View solution in original post

3 REPLIES 3

gfriedl
Extreme Employee

Sure you can do that !

CmpB-L3:1(config-if)#% brouter port 1/10 vlan 3999 subnet 192.168.234.1/24
CmpB-L3:1(config-if)#% vlni 1/10
alias% show interfaces gigabitEthernet vlan 1/10
====================================================================================================
Port Vlans
====================================================================================================
PORT DISCARD DISCARD DEFAULT VLAN PORT UNTAG DYNAMIC UNTAG
NUM TAGGING TAGFRAM UNTAGFRAM VLANID IDS TYPE DEFVLAN VLANS VLANS
-----------------------------------------------------------------------------------------------------------
1/10 disable false false 0 0 normal disable P
----------------------------------------------------------------------------------------------------
--> port 1/10 is not member of any VLAN so far ...

CmpB-L3:1(config-if)#% sho brouter
Port Vlan Id
==== =======
1/10 3999

As long as "tagging" is disabled, you can't add VLANs ...
CmpB-L3:1(config-if)#% vlan members add 1 1/10
Brouter port cannot be added to VLAN.
Error: Operation not allowed
.. but now you change that ..
CmpB-L3:1(config)#% int g 1/10
CmpB-L3:1(config-if)#% encapsulation dot1q
CmpB-L3:1(config-if)#% vlan members add 1 1/10
CmpB-L3:1(config)#% vlni 1/10
alias% show interfaces gigabitEthernet vlan 1/10
====================================================================================================
Port Vlans
====================================================================================================
PORT DISCARD DISCARD DEFAULT VLAN PORT UNTAG DYNAMIC UNTAG
NUM TAGGING TAGFRAM UNTAGFRAM VLANID IDS TYPE DEFVLAN VLANS VLANS
-----------------------------------------------------------------------------------------------------------
1/10 enable false false 1 1 normal disable P
--------------------------------------------------------------------------------

--> and finally port is Brouter and member of VLAN 1 in this example.
Hope this helps!

Thanks gfriedl,

OK so encapsulation dot1q command will do the magic. Just a quick question, so in your switch is VLAN 1 type a port-mstprstp vlan? 

Also I did a quick test on GNS3 running 8.10.1.0 and couldn't configure VLNI, the switches that have the wireless bridging are running version 9, but can't remember exact version. Will this work on version 9?

Example:

EDGE:1(config)#interface gigabitEthernet 1/8
EDGE:1(config-if)#vl
EDGE:1(config-if)#vln
EDGE:1(config-if)#vlni ?

 

EDGE:1(config)#vl?
vlacp vlan

 

Hi, 

Yes, vlan type is port-mstprstp and it works with 8.10 release. 

For your information, "vlni 1/10" is an alias for "show interfaces gigabitEthernet vlan 1/10" in the application ACLI (terminal client). 

regards, 

TQU

 

GTM-P2G8KFN