Showing results for 
Search instead for 
Did you mean: 

Android maybe don´t have internet connection

Android maybe don´t have internet connection

New Contributor III

Hi everyone,

I´ve some strange situation with Android Smartphones in our Aerohive/Extreme Network (Mix of AP250 and 305C) environment.
The Android devices itself get´s an valid IP and authenticated to the Wifi but shows the information “maybe don´t have internet connection”.
Actual Workaround: Ping the device. The first 2 packages are lost, but than the device replies and shows connected.
I´ve started this discussion last year, but with Covid-19 the situation stuck.

I´ve also found that we are not the only one with this situation.

I can confirm that DNS port 53 and 853 is open for this dedicated Wifi VLAN on our firewall.
I´ve added the DNS ports for the native VLAN of the APs to this internal DNS server, now.

Does anyone has an idea, if this won´t help, how we could troubleshoot this?

Thankful for every idea!



New Contributor III


I want to send an update about this topic.
We found the root cause for our problem, but I´m unsure how to solve it.
The ARP-cache on our firewall which is also the Gateway for our Guest Network seems to get some wrong information from the Aerohive environment.
The Guest Wifi has a short Lease time on DHCP side (5min, increased to 15min now).
The client itself gets the correct IP from DHCP Server (same VLAN/subnet, Windows Server), but the Firewall still get´s the wrong information after a arp-cache clear.
We deleted the "wrong" client in the IQ Management and cleared the ARP-cache once again and the problem was solved for this device.

We found an option in the "Management Options" called "disable Proxy-ARP":
Would it make sense to activate this option in a Wifi environment?
Arp-Caches are written on the Gateway and Switch devices.

View solution in original post


New Contributor III

Hi, I´m back with this topic.

It´s been a while since I started this topic and we made some changes in our infrastructure.
We changed the firewall to another developer and also deployed the Aerohive/Extreme APs in a new office, where we are working with Samsung Android devices ONLY.

The situation is still the same: Device gets an IP over DHCP but the Wifi information "mabye don´t have internet connection".

New Contributor II

Hi @juergen.dannewitz . Are you guys still having this issue?

New Contributor III

We upgraded the HiveManager to and all APs to 10.3r3 without any changes.
The ticket is still running.

Aerohive Remote Package Capture shows

“Radiotap data does past the end of the radiotap header”. (Wireshark)

DNS validated over DNS server debug log. Name resolution and followed firewall log shows the access.

The only data package that is blocked in some cases is UDP-1900 Multicast.
I don´t expect that the Android device is checking his Internet connection over this port.

If it would be only one device, but it´s changing between several Android devices from different developers (Samsung, Huawei, OnePlus,...).
IPhone and Windows running fine.

It´s frustrating.

New Contributor III

Hi. No we don´t using ipv6. I had this situation with the last firmware updates.

Which one are you using that seems to work?

I´ve opened a ticket over our partner. We will see.

New Contributor II

Do you have IPV6 in your environment I recently had basically this same issue with Android. I fixed it by downgrading firmware version.