10-16-2019 12:08 PM
Hi everyone,
I have an 7161 AP. I want to deliver ip to wireless clients using DHCP: But I just can’t do it, am i missing something here?
here is my wlan config:
!
wlan TestWIFI
ssid Test
enforce-dhcp
vlan 23
encryption-type ccmp
authentication-type none
no answer-broadcast-probes
wireless-client inactivity-timeout 600
wpa-wpa2 psk 0 test1234
no wing-extensions wing-load-information
no client-load-balancing allow-single-band-clients 5ghz
no client-load-balancing allow-single-band-clients 2.4ghz
ip arp trust
!
dhcp policy config:
dhcp-server-policy dhcpAP
dhcp-class classdhcp
option user-class 1
multiple-user-class
dhcp-pool pool23
network 192.168.23.0/24
address range 192.168.23.5 192.168.23.254 class classdhcp
lease infinite
domain-name pool
!
Solved! Go to Solution.
10-16-2019 02:28 PM
emery0123,
Unless the config entry is part of the AP’s override section, you don’t have a ‘use’ statement in the AP’s config that says to actually use the DHCP server policy you created.
Remember, in WiNG, you create various policies and such….and then in the AP or controller profiles, you have to say that you want to use them. In the CLI, you see this as ‘use’ statements. Look through your config and you’ll see a few in there already. Examples I see:
So somewhere, either in the AP Profile itself or in the AP’s override section, you need to have a statement that says to use your created DHCP Policy. It would look like this:
If you do already have this statement somewhere that I’m not seeing, then the issue lies elsewhere.
10-16-2019 05:31 PM
Thanks Chris Kelly for the reply, it looks like this one line was problem, I didn’t make use of my dhcp policy that I created.
10-16-2019 02:28 PM
emery0123,
Unless the config entry is part of the AP’s override section, you don’t have a ‘use’ statement in the AP’s config that says to actually use the DHCP server policy you created.
Remember, in WiNG, you create various policies and such….and then in the AP or controller profiles, you have to say that you want to use them. In the CLI, you see this as ‘use’ statements. Look through your config and you’ll see a few in there already. Examples I see:
So somewhere, either in the AP Profile itself or in the AP’s override section, you need to have a statement that says to use your created DHCP Policy. It would look like this:
If you do already have this statement somewhere that I’m not seeing, then the issue lies elsewhere.
10-16-2019 12:36 PM
Thanks for the reply, I just did what you asked, seems like doesn’t work.
Here is my profile config:
profile ap71xx XX
no mint mlcp ipv6
bridge vlan 10
bridging-mode local
ip arp trust
ip igmp snooping
ip igmp snooping querier
ipv6 mld snooping
ipv6 mld snooping querier
area Test123
ip default-gateway 192.168.23.1
no autoinstall configuration
no autoinstall firmware
crypto ikev1 policy ikev1-default
isakmp-proposal default encryption aes-256 group 2 hash sha
crypto ikev2 policy ikev2-default
isakmp-proposal default encryption aes-256 group 2 hash sha
crypto ipsec transform-set default esp-aes-256 esp-sha-hmac
crypto ikev1 remote-vpn
crypto ikev2 remote-vpn
crypto auto-ipsec-secure
crypto remote-vpn-client
interface radio1
channel 6
rate-selection opportunistic
placement outdoor
rts-threshold 1
wlan TestWIFI bss 2 primary
meshpoint Test123 bss 1
non-unicast tx-rate lowest-basic
antenna-mode 3x3
no dynamic-chain-selection
antenna-diversity
interface radio2
channel 132
rate-selection opportunistic
placement outdoor
rts-threshold 1
meshpoint Test123 bss 1
antenna-mode 3x3
no dynamic-chain-selection
interface radio3
shutdown
placement outdoor
interface ge1
switchport mode access
switchport access vlan 25
use ip-access-list in BROADCAST-MULTICAST-CONTROL
ip arp trust
interface ge2
shutdown
interface vlan10
ip address 10.10.10.2/24
interface vlan25
ip address 192.168.25.2/24
interface vlan23
ip address 192.168.23.1/24
ip dhcp client request options all
use ip-access-list in BROADCAST-MULTICAST-CONTROL
interface wwan1
interface pppoe1
use firewall-policy default
no events on
logging forward critical
controller hello-interval 60 adjacency-hold-time 180
no cdp run
no lldp run
misconfiguration-recovery-time 0
service pm sys-restart
meshpoint-device Test123
path-method uniform
hysteresis period 60
10-16-2019 12:20 PM
Common mistake is forget to assign IP address to vlan. Please try below
(config)#self
(config-device-)#interface vlan 23
(config-device-if-vlan23)#ip address 192.168.23.1/24