Showing results for 
Search instead for 
Did you mean: 

VX9000 Initial Setup

VX9000 Initial Setup

New Contributor II

Hi everyone. I hope some of you will be able to help me.

I’m attempting to setup a virtual VX9000 appliance on Microsoft Hyper-V which is running on Windows Server 2016 DataCenter.

Now I am familiar, but by no means an expert on WING as we have two standalone RFS4010 controllers running WING

I’m still evaluating which version of WING to use on the VX9000 and to that end I’ve setup versions of the VX9000 running both WING &

The VX9000 running on initial startup doesn’t receive a DHCP address from our DHCP Server (Windows 2016 Server Standard) and the status of interface VLAN1 given by SHOW IP INTERFACE BRIEF is “unassigned(DHCP)” although STATUS & PROTOCOL are both shown as up. Changing the VLAN1 IP address to a static one still results in the VX9000 still not connecting. PINGS and connecting to the Web GUI fail.

Contrast this with the WING version which gets a DHCP address immediately on first startup and is reachable via the DHCP address and when changed to a static IP.

Long setup, but hopefully now a shorter question:

What am I missing? What has changed between these WING versions?

Many Thanks.


New Contributor II

Hi Martin8052,

Thanks for your reply.

Yes, this was the same response I had from GTAC; that basically to use WING on Hyper-V (I’m using Windsows Server 2016), a Legacy Network Adapter has to be used. I agree with you, this seems a backward step and shouldn’t be the solution. I hadn’t tried any other “7” WING versions prior to thanks for the info on 7.2.x. &

Kind Regards. 

View solution in original post


New Contributor III


is it possible to get news about this bug? 

Don't you think it would be a good idea to write this issue in the release notes ?

or update the VX installation document which is dated 2018 ? Why this lack of documentation? 

I don't know if Extreme is working on solving this problem? I have a lot of customers under Hyper-V and today Migration impossible, introduction of new WIFI 6 AP impossible without leaving in a legacy mode. Customers don't want that…






Update: YES, i can communicate on version only on legacy mode.




Sorry folks,

WiNG not work with Hyper-V in any cases. 



Hi folks,

We are moving to new server and works fine only with Legacy Mode (consume more CPU and is limited to 100M).

I can open gtac or wait for new version?