cancel
Showing results for 
Search instead for 
Did you mean: 

Compare Device VLAN definition the same for desired and current, but XMC shows its different?

Compare Device VLAN definition the same for desired and current, but XMC shows its different?

Anonymous
Not applicable

Hi,

Have the following output when I run the enforce preview, for Compare Device Configuration:

dc1a8047a72f4ef79e38704c3d09eb28_a1d6d72a-eec4-4f0b-a9ba-9a4138f7076e.png

The configuration in XMC has originally be determined by importing the switch to a service definition, so as to synchronise the configuration.

Equally if use the ‘Reload Device’ button before going into the ‘Enforce Preview’ I get the same results as above.

What I can’t tell from this is why some lines are showing different on the current configuration to the desired with red arrow? Looking at the screenshot above it can be observed they look the same on both sides?

My concern is when hitting ‘Enforce’ what is it going to be written to the switch and possibly break something?

There is a slight difference in the lines showing green ticks and red arrows, and that is anything that is showing ‘SNOOPING’ but has an IP address / VRRP next to it is green. Anything that is showing just ‘SNOOPING’ has a red arrow. Still, the desired the current seem to be the same, so not sure what the complaint is, and thereby the repercussions of doing an enforce.

XMC Version 8.5.2.6

Many thanks in advance

3 REPLIES 3

Anonymous
Not applicable

Thanks both for posting.

@M.Nees I decided to upgrade to 8.5.5 as I was see other oddities.

@Ludovico Stevens Ah….. The VLAN page was long, even when I checked the ‘Show Differences Only’, so I never see it. I needed to scroll all the way to the bottom of the page before it showed up.

For some reason today I am not seeing so many differences, but found one that explains the difference:

921bc282969c40d8bbd2427f6bb19d00_eda162ed-9a93-4a27-aa1f-7ec4b2f261b8.png

Seems that the switch has a configuration entry for IGMP that XMC doesn’t reflect.

I’ve tried the ‘Reload Device’ and saved, then gone back in but its still the same? Do you know how I would synchronise that?

The ‘sync from site’ button, I’m not sure exactly what the action of that button does, would that help?

Many thanks

Ludovico_Steven
Contributor III

Martin, there is supposed to be a lower pane showing more vlan config details, for the VLAN record you select. You probably have deltas there:

9761ad44587c4787a3d1781d0336a441_9a6ebad3-8426-4679-9e88-1281ef088a82.png

 

M_Nees
Contributor III

Hi Martin,

we need to know what SNOOPING, will tell us exactly.

I also do not know that.

Can you provide us a “show vlan i-sid” of the switch ?

Because XMC Versions 8.5.4 and 8.5.5 solves a lot of known bug, i would upgrade XMC and check is this output remains (or maybe will be gone).

 

BR,

Matthias

GTM-P2G8KFN