Showing results for 
Search instead for 
Did you mean: 

Cisco IP Phone wrong vlan

Cisco IP Phone wrong vlan

New Contributor
Cisco IP Phone refuses to go on the voice vlan.
Data vlan is untagged. Voice vlan is tagged.
LLDP is configured as follows:

configure lldp port 2:33 advertise system-name
configure lldp port 2:33 advertise vendor-specific dot3 mac-phy
configure lldp port 2:33 advertise vendor-specific med capabilities
configure lldp port 2:33 advertise vendor-specific med power-via-mdi
configure lldp port 2:33 advertise vendor-specific med policy application voice vlan BH-Voice dscp 46

This is the same config on all the other ports where the phones work just fine, just this one phone doesn't go on the correct vlan.
I have deleted vlan config on the port and reentered the LLDP config again.
Disabled port and power to the port. Deleted DHCP address. Waited 10 minutes then enabled the port and power. I even tried only having the voice vlan tagged on the port and it didn't work.

Any ideas? Only thing I haven't done yet is reboot the switch.


New Contributor
Restarting the switch stack fixed the issue for this phone and another phone that was on wrong vlan.
Probably a bug in the software would be my guess.

One more check would be to run these commands to make sure that vlans are tagged and untagged on the port

sh conf detail | include "vlan Data add ports"
sh conf detail | include "vlan Voice add ports"
one last check
verify lldp on the port is enabled:
enable lldp port (port#)

If that doesn't work, do a packet capture on that port and look for Avaya option 242 in your DHCP advertisement.

New Contributor
It's not the phone. Did factory reset and it upgraded twice and still went on wrong vlan. Took phone to a Cisco switch, got IP on voice vlan. Put phone on another Extreme switch in a different closet and phone gets IP on voice vlan. Take it back to original closet plug in on different port, gets IP on the Data vlan. All the other phones on that closet are on the voice vlan.
I'm going to reboot the switch tonight and see if that fixes it.