cancel
Showing results for 
Search instead for 
Did you mean: 

Port Congestion

Port Congestion

Julian_Eble
New Contributor II
Hello Community,

I have been noted some congestion on ports connected to my GGC port channel and I can't figure out what is happening here.
Is there any issues about the flow control o buffer sharing?

The max shared buffer on ports are at 100% already and the version of the box (X460-24T) is 15.5.4.2 v1554b2

There's 4 sharings and all are droping packets.

Any thought about that?

Port Congestion Monitor Tue Jul 28 22:10:47 2015Port Link Packet
State Drop
================================================================================
1 A 40915183
2 A 41080619
3 A 40892745
4 A 40811054
5 A 39540703
6 A 39739627
7 A 39937877
8 A 40004508
9 A 40476716
10 A 40276213
11 A 40333055
12 A 40588116

Thanks in advance,
8 REPLIES 8

Fauriant_Trista
New Contributor
Julian,

in our environment we have a similar problem with IP Phones and it was due to CRC on stack cables between the stacked x460. Are you using standalone switch or stacked switchs ? If it is stacked, I suggest of watching the stack cables state with "show ports stack-port rxerror".

Tristan

Julian_Eble
New Contributor II
Hello Bill,

Jumbo-frame is already on.
This switch is only for server communcation to our network, there's is a Google Global cache, Akamai and Netflix connected and then a port-channel of 20Gbps total (2x10Gbps) to a Juniper MX80.
We don't have Aruba at all, just Ubiquiti in some wireless clients.

And about the question of qos profile, only one configured as below:

SW-GGC # sh configuration | i qoscreate qosprofile "QP6"
configure dot1p type 7 qosprofile QP6

Bill_Stritzinge
New Contributor III
Julian,

Do you by chance have Aruba wireless in your environment? I would enable jumbo frames on all of the switches and see if that resolves your issues... "enable jumbo-frame port all" - Have seen in the field this occur and enabling jumbo frames has resolved it every time. There is no penalty to having jumbo-frame enabled.

Give it a shot...

Bill

OscarK
Valued Contributor
I think you are suffering from microbursts where the traffic shortly (a few milliseconds) exceed 100 % utilization. show port util cannot show microbursts and on high speed ports buffer quickly runs out. With all ports averaging above 50 % I bet you if you would take a look in real life those ports are on 100 % now and then.

One other thing, did you create all qosprofiles ? Every qosprofile you create takes away a bit of the shared buffer space from the ports. (check show port buffer).
https://gtacknowledge.extremenetworks.com/articles/Solution/Prevent-packet-drops
GTM-P2G8KFN