Port channel with C3560 cisco switch
Options
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Get Direct Link
- Report Inappropriate Content
‎11-11-2015 07:48 PM
I need to setup a port channel with a Cisco switch. I just want to verify the steps I need to perform.
This is what I have on the Cisco side for the port channel config so far:
interface Port-channel1
description Etherchannel to summit
switchport trunk encapsulation dot1q
switchport mode trunk
interface GigabitEthernet0/49
description Trunk to summit GI2/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/50
description Trunk to summit
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/51
description Trunk to summit
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/52
description Trunk to summit
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
On the extreme side:
en sharing 1:48 grouping 1:48,2:48,3:48,4:48 lacp
con port 1:48 des port_channel_cisco
Then I would just remove ports from default vlan:
con default del port 1:48,2:48,3:48,4:48
Then add them to my vlans
con server add port 1:48,2:48,3:48,4:48 untagged
etc.....
This is what I have on the Cisco side for the port channel config so far:
interface Port-channel1
description Etherchannel to summit
switchport trunk encapsulation dot1q
switchport mode trunk
interface GigabitEthernet0/49
description Trunk to summit GI2/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/50
description Trunk to summit
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/51
description Trunk to summit
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/52
description Trunk to summit
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
On the extreme side:
en sharing 1:48 grouping 1:48,2:48,3:48,4:48 lacp
con port 1:48 des port_channel_cisco
Then I would just remove ports from default vlan:
con default del port 1:48,2:48,3:48,4:48
Then add them to my vlans
con server add port 1:48,2:48,3:48,4:48 untagged
etc.....
4 REPLIES 4
Options
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Get Direct Link
- Report Inappropriate Content
‎11-18-2015 06:26 PM
Funny, never had a problem creating a LAG between Extreme/Enterasys, Enterasys/Juniper, Juniper/Extreme, or any other vendor. Apparently the Cisco is the oddball here. Glad you got it figured out.
Options
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Get Direct Link
- Report Inappropriate Content
‎11-18-2015 05:17 PM
Here was the final solution that worked for me:
https://gtacknowledge.extremenetworks.com/articles/Solution/LACP-incompatibity-between-extreme-and-c...
https://gtacknowledge.extremenetworks.com/articles/Solution/LACP-incompatibity-between-extreme-and-c...
Options
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Get Direct Link
- Report Inappropriate Content
‎11-14-2015 03:58 PM
I can't ping across this new port channel? I do a summary and it looks up. Ideas?
Options
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Get Direct Link
- Report Inappropriate Content
‎11-11-2015 07:59 PM
The cisco is going to want to negotiate the port channel/LAG via PaGP. The industry standard for this protocol is LACP, which you'll want to make sure and specify on the cisco. In your channel-group command, replace "desirable" with "active". This will let the cisco know to use LACP instead of PaGP, and your LAG should be negotiated and work just fine.
