Showing results for 
Search instead for 
Did you mean: 

Mutlicasting VOSS only

Mutlicasting VOSS only


Using 5420 as edge device, running VOSS One vlan (33) is for multicasting. Currently both the sending unit and receiving unit are on the same switch, and both ports are on the same vlan. The two ports are untagged. The multicasting is working (sender is a PC to an encoder, receiver is a decoder to a TV, with network in between). But it jerks. Just wondering if I missed something in the config.

Snippets of the running config.

router isis
spbm 1
spbm 1 nick-name b.54.25
spbm 1 b-vid 4051-4052 primary 4051
spbm 1 multicast enable
spbm 1 ip enable

vlan create 33 name "AHEC AV" type port-mstprstp 0
vlan members 33 1/1-1/48 portmember
vlan i-sid 33 20033
interface vlan 33
ip igmp proxy
ip igmp snooping
ip igmp upnp-filter
ip igmp snoop-querier-addr

ip igmp version 3


This switch is hooked up to a 8400 switch for further routing, but the multicast traffic is just within the switch (5420). The address of is the clip address of the 5420 switch. In the future, traffic may go to one more switch, also a 5420.

Thanks for all the help.


Extreme Employee

Make sure TTL > 1 on your multicast streams ?
The two config methods have a distinction..

IGMP Snooping on the VLAN, results in multicast forwarding, but constrained to the VLAN/L2VSN

MVPN-ISID on the VLAN, results in multicast forwarding within and across all VLANs configured with the same L3 I-SID context, as well as L3VSNs with the same L3 I-SID.

Yes, TTL is 30. Thanks for explaining the differences between IGMP Snooping and MVPN-ISID.


Hi Jave (and others),

I tried this, vs the older method of igmp snooping, and snoop-querier-addr. The config-lite worked, but so did the older method. I  have multicasting working using both methods. Again, this is on VOSS (5420 using VOSS), and for testing purposes, both my sender and receiver are on the same switch, and the same vlan. In production, it will be on the same vlan, but will probably span two switches (so using L2VSN).

One thing we noticed, is that speeds/bandwidth are quite slow before we get hesitation in the video. Using multicast Hammer, I got to speeds of about 30Mb before losing packets. Switching multicast Hammer to unicast, I got speeds of about 400 Mb before losing packets. While these speeds are enough for TV (1080p) and slow computer imaging, we are coming up with needs of higher bandwidth.

I checked the switch (show interf giga rate-limit), and there is no rate-limiting of any kind on any port.

I don't know if a Premier license (with it's extra benefits) would be advantageous or not. We don't have it. Or if running this switch under EXOS would help, or if there is some tweaks we could do.

Thanks for any hints anybody can give.


Thanks, Jave.  I need to look further into this. Unfortunately, I do need an IP address on this vlan, as some of the devices need internet access. I have the IP address on our "core" routers (this switch is connected to our routers). Also, this is a L2 vlan, with no need to jump subnets/networks. I presume this would still work for L2 (except, of course, for my need to have an IP address in this vlan).