cancel
Showing results for 
Search instead for 
Did you mean: 

QoS on ERS 4900 HW:03

QoS on ERS 4900 HW:03

Martin_Sebek
New Contributor III
We have got complaints from users about low network performance. The users are behind newly deployed ERS 4900 switches with 10Gbps uplinks. After some investigation we have addressed it as a QoS issue. When queue-set other than 1 is set it is not possible to use the whole bandwidth of the access port. For example, if you set queue-set to 4, the speed of 1Gbps port is shaped to 250Mbps (1000/4) and it is not possible to reach higher speed. This problem can be reproduced only on switches with HW revision 03. We also have switches with HW02 and they behave correctly.

Is there anyone else experiencing the same issue?

As a workaround we set only one queue which technically disables QoS, but the users are much happier.
9 REPLIES 9

Martin_Sebek
New Contributor III
Hello Ludovico,

you nailed it. I haven't changed the buffering sharing setting initialy and it was set to default large. Changing it to maximum helps.

Ludovico_Steven
Contributor III
If you are seeing dropped on no resources on the access ports, it means packets are QOS tail dropped as they are queued on the access ports (beware of that stat, it only works for packets tail dropped on best effort queue; as of 5.8 you have QOS queue stats which work across all queues). With the 10G uplinks the traffic might present bursts which saturate the available QOS queues on the 1g access ports.
Apart from setting the qos queue-set to 1 (which effectively completely disables QOS on the switch), the only setting which can help is the QOS buffer sharing setting: Regular, Large, Maximum. This determines how much of the unused QOS queues from other ports/queues on the system a given port can use. You do not say what setting you have here. You need to try increasing this setting, and if to no avail, then reducing QOS queue-set is the only option.

Martin_Sebek
New Contributor III
Hello Alan,

rate-limit can be set only for broadcast and multicast packets. Anyway there is no rate-limit set on the uplink.

Alan_Jackson
New Contributor
Martin disable the rate limit on the 10G SFP port in question..
GTM-P2G8KFN