10-25-2019 07:26 AM
Hello!
Could somebody help with issue?
RFS-4010, AP 7632, WiNG 5.9.6
AP don’t receive IP from Controller.
AP connected directly to Controller - to port 2.
Config from Controller:
!
dhcp-server-policy DHCPv208
dhcp-class 1
option user-class 1
multiple-user-class
dhcp-pool v208
network 10.23.208.0/24
address range 10.23.208.32 10.23.208.55 class 1
default-router 10.23.208.30
dns-server 8.8.8.8
!
!
profile ap7632 default-ap7632
autoinstall configuration
autoinstall firmware
…
interface ge1
switchport mode trunk
switchport trunk allowed vlan 204,206,208
switchport trunk native vlan 208
interface vlan204
ip address dhcp
interface vlan206
ip address dhcp
interface vlan208
ip address dhcp
ip dhcp client request options all
interface pppoe1
use dhcp-server-policy DHCPv208
use firewall-policy default
use client-identity-group default
logging on
controller vlan 208
service pm sys-restart
router ospf
adoption-mode controller
!
!
rfs4000 B4-C7-99-F9-D7-A9
use profile default-rfs4000
use rf-domain default
hostname rfs4000-F9D7A9
license AP DEFAULT-6AP-LICENSE
license ADSEC DEFAULT-ADV-SEC-LICENSE
interface up1
switchport mode trunk
switchport trunk allowed vlan 204,206,208
switchport trunk native vlan 208
switchport trunk native tagged
interface ge2
no shutdown
switchport mode trunk
switchport trunk allowed vlan 204,206,208
switchport trunk native vlan 208
interface ge3
switchport mode trunk
switchport trunk allowed vlan 204,206,208
switchport trunk native vlan 208
interface ge4
switchport mode trunk
switchport trunk allowed vlan 204,206,208
switchport trunk native vlan 208
interface ge5
switchport mode trunk
switchport trunk allowed vlan 204,206,208
switchport trunk native vlan 208
interface vlan1
description "Virtual Interface for LAN by Wizard"
ip address 192.168.0.1/24
no ip dhcp client request options all
interface vlan204
interface vlan206
interface vlan208
ip address 10.23.208.30/24
use dhcp-server-policy DHCPv208
!
ap7632 94-9B-2C-E8-02-0B
use profile default-ap7632
use rf-domain default
hostname ap7632-E8020B
!
!
end
Config from AP:
! Configuration of AP7632 version 5.9.6.0-007R
!
!
version 2.7
!
dhcp-server-policy DHCPv208
dhcp-class 1
option user-class 1
multiple-user-class
dhcp-pool v208
network 10.23.208.0/24
address range 10.23.208.32 10.23.208.55 class 1
default-router 10.23.208.30
dns-server 8.8.8.8
!
!
profile ap7632 default-ap7632
autoinstall configuration
autoinstall firmware
…
interface ge1
switchport mode trunk
switchport trunk allowed vlan 204,206,208
switchport trunk native vlan 208
interface vlan204
ip address dhcp
interface vlan206
ip address dhcp
interface vlan208
ip address dhcp
ip dhcp client request options all
interface pppoe1
use dhcp-server-policy DHCPv208
use firewall-policy default
use client-identity-group default
rf-domain-manager capable
logging on
controller vlan 208
service pm sys-restart
router ospf
adoption-mode controller
!
Thank you!
10-25-2019 03:10 PM
Also...it appears that you have applied the DHCP server policy to BOTH the RFS4K and the AP Profile.
Did you mean to do that? Normally, the DHCP service would only be run on the controller or on an AP, but not both.
10-25-2019 03:09 PM
This function is purely optional.This essentially allows you to create customized DHCP values to be assigned to specific users. (In the case of WiNG, it only supports providing users of different User Classes with a different IP address range).
It does require not only creating the User class info on the DHCP server side in WiNG, but also logging onto each individual user workstation/laptop/device and entering the desired User Class value as well. The value you use would somehow describes a single user or some group of users that need different DHCP value(s) than others (In WiNG, it can only describe a different IP range to get an address from). That User Class value you enter on the workstation side is then recognized by the DHCP server and as such, the WiNG DHCP server will provide an IP address from a different address range in the DHCP lease - based on the specified range for that User Class value that was seen used by that user in their DHCPDISCOVER or DHCPREQUEST message.
Bottom line, if all users should be getting the same DHCP lease info, you do not need to do anything with the User Class setup.
10-25-2019 10:12 AM
Issue resolved:
!
dhcp-server-policy DHCPv208
dhcp-class 1
option user-class 1
multiple-user-class
dhcp-pool v208
network 10.23.208.0/24
address range 10.23.208.32 10.23.208.55 class 1
default-router 10.23.208.30
dns-server 8.8.8.8
!
have to be just address range 10.23.208.32 10.23.208.55
Could somebody explain what exactly mean DHCP server Class Policy and exactly what for ?
Thank you!