Showing results for 
Search instead for 
Did you mean: 

AP621 model does not return SNMP data via snmpwalk

AP621 model does not return SNMP data via snmpwalk

New Contributor

hello @ckelly@Christoph_S , @Christopher_Fra , @arichter 

We have 2 RFS6000 controllers and 35 devices of this model in our environment, but I can't retrieve SNMP data from them. We have another 12 devices of the AP7532 model, and I can easily get the information from them.




$ snmpwalk -v2c -c cti (AP621)
Timeout: No Response from






$ snmpwalk -v2c -c cti
iso. = STRING: "AP7532 Access Point, Version MIB=01a"
iso. = OID: iso.
iso. = Timeticks: (24005400) 2 days, 18:40:54.00
iso. = ""
iso. = STRING: "AP-A13-1314"



What is blocking the AP621 model? How can this be fixed?


I tried to follow the steps in the link below, but an error occurred. I think it's a bug.


rfs01(config)*#ip snmp-access-list cti
rfs01(config-ip-snmp-acl-cti)*#permit any
% Error: Invalid IPv4/mask format
rfs01(config-ip-snmp-acl-cti)*#permit ?
  A.B.C.D/M  Source IP address range to match
  any        Any source IP address
  host       Single host address

rfs01(config-ip-snmp-acl-cti)*#permit any ?

rfs01(config-ip-snmp-acl-cti)*#permit any 
% Error: Invalid IPv4/mask format


Thank you in advance!!!


Extreme Employee

These models all goes back many years, and I've not dealt with the dependent mode AP models when it comes to SNMP operation, so can't really say what is expected to be seen on the controller. But yes, normally, if a function is disabled, I would expect a UI to indicate this. At the same time though, there are other cases where the UI does not exactly reflect device status, so this could just be a case where the controller software was not properly changed to reflect the actual disabled SNMP state of the AP621.

As far as enabling it...I don't think this can be done. The actual AP621 firmware itself contains the code that drives how the AP operates. So if it's disabled in the AP firmware code, then that would be a configuration that cannot be changed by the user (hard coded as disabled).

I'm wondering if it might be possible to extract the values you are looking for in another way though. What information are you needing to see that you want from the snmpwalk?

New Contributor

Thank you for the test lab, @Christopher_Fra


I asked a former colleague who no longer works with us, and he doesn't remember. But the strange thing is that the controller doesn't show SNMP as disabled.

Shouldn't that happen? Is there any way to enable SNMP directly on the AP621?

Extreme Employee

@Christopher_Fra was kind enough to setup a test system using an RFS6000, AP621, and AP7532, all running

He was able to replicate exactly what you are seeing. After discussion, we're fairly certain that due to the reduced memory in the AP621 that along with other features and functions being disabled or reduced in this AP model, that SNMP was also disabled. (This would also explain why my AP622 does respond to an snmpwalk - it does not have the smaller RAM footprint)

Was there ever a time when your AP621's did respond to an snmpwalk?

New Contributor


I had already done this, but for peace of mind, I did it again.

It didn't solve the issue. SNMP data is still not returning.

Honestly, I believe with this firmware version, it won't work. We would need to test it with another version.

We know that the problem is clearly in the firmware. It would be interesting for Extreme to release an upgrade to the latest available version or provide a patch for corrections. I understand it's already an end-of-life product, but still, firmware release is the least we expect in a case like this.

What can you do about it? I'm almost begging for the firmware because I've already tried all other attempts.