cancel
Showing results for 
Search instead for 
Did you mean: 

The ap's ip address is incorrect on adoption status result.

The ap's ip address is incorrect on adoption status result.

zlinuxboy
Contributor

I deploy 3 AP7522s, one of them is VC. here is the context of profile ap7522 default-ap7522

profile ap7522 default-ap7522
use enterprise-ui
ip name-server 221.176.88.95
ip default-gateway 192.168.9.254
autoinstall configuration
autoinstall firmware
use radius-server-policy WERSP
crypto ikev1 policy ikev1-default
isakmp-proposal default encryption aes-256 group 2 hash sha
crypto ikev2 policy ikev2-default
isakmp-proposal default encryption aes-256 group 2 hash sha
crypto ipsec transform-set default esp-aes-256 esp-sha-hmac
crypto ikev1 remote-vpn
crypto ikev2 remote-vpn
crypto auto-ipsec-secure
crypto load-management
crypto remote-vpn-client
interface radio1
data-rates gn
wlan wing-hkxd bss 1 primary
interface radio2
wlan wing-hkxd bss 1 primary
interface ge1
switchport mode trunk
switchport trunk allowed vlan 7-10
switchport trunk native vlan 9
interface vlan1
ip address dhcp
ip address zeroconf secondary
ip dhcp client request options all
interface pppoe1
use firewall-policy default
ntp server 0.pool.ntp.org
use client-identity-group default
virtual-controller auto
virtual-controller management-interface ip address 192.168.9.140/24
virtual-controller management-interface vlan 9
rf-domain-manager capable
logging on
service pm sys-restart
router ospf
adoption-mode controller
!
rf-domain default
timezone Asia/Shanghai
country-code cn
use smart-rf-policy hkxd
use nsight-policy default
!
ap7522 74-67-F7-04-31-5C
use profile default-ap7522
use rf-domain default
hostname ap7522-04315C
interface vlan9
ip address 192.168.9.143/24
!
ap7522 74-67-F7-04-4F-A8
use profile default-ap7522
use rf-domain default
hostname cz3-ap46
!
ap7522 74-67-F7-04-4F-C4
use profile default-ap7522
use rf-domain default
hostname ap7522-044FC4
!
ap7522 74-67-F7-04-53-20
use profile default-ap7522
use rf-domain default
hostname ap7522-045320
interface vlan9
ip address 192.168.9.144/24
!
ap7522 74-67-F7-A1-AE-58
use profile default-ap7522
use rf-domain default
hostname ap7522-A1AE58
interface vlan9
ip address 192.168.9.142/24
!
ap7522 74-67-F7-A2-DA-54
use profile default-ap7522
use rf-domain default
hostname ap7522-A2DA54
interface vlan9
ip address 192.168.9.141/24
no adoption-mode

the VC’s IP is 192.168.9.140

the 3 AP’s mac and IP are:

74-67-F7-04-31-5C : 192.168.9.143

74-67-F7-04-53-20 : 192.168.9.144

74-67-F7-A2-DA-54 : 192.168.9.141

but when `show adoption status` on vc

ap7522-04315C> show adoption status
Adoption Mode: CONTROLLER
--------------------------------------------------------------------------------------------------------------------------------
DEVICE-NAME VERSION CFG-STAT MSGS ADOPTED-BY LAST-ADOPTION UPTIME IPv4-ADDRESS
--------------------------------------------------------------------------------------------------------------------------------
ap7522-045320 5.9.8.4-002R configured No ap7522-04315C 0 days 00:18:52 0 days 00:21:01 192.168.9.140
ap7522-A2DA54 5.9.8.4-002R configured No ap7522-04315C 0 days 00:30:23 0 days 15:23:04 192.168.9.141
---------------------------------------------------------------------------------------------------------------------------------

The ap7522-045320’s IP was change from 9.144 to 9.140(VC), what is wrong?

 

Question2:

I serial console to ap7522-045320, the hostname have a suffix ‘*’:

ap7522-045320*#

what does it mean?

1 ACCEPTED SOLUTION

ckelly
Extreme Employee

Okay, that makes more sense then.

So in the neighbor output from 04315C, we can see its two neighbors.

So 04315C has a level-1 MINT link to each of these APs, as expected.

This is what I would expect to see.

View solution in original post

15 REPLIES 15

zlinuxboy
Contributor

@Chris Kelly 

well, here are the logic
1. Through the profile config, they will elect a vc, and then assign 9.140 to the vc as secondary ip.
2. The device override config will assign static to the ap.
3. ap7522-04315c was elected as vc, it's secondary ip is 9.140, the primary ip is 9.143
4. ap7522-045320's ip is 9.144, ap7522-a2da54's ip is 9.141

so, I think the result of `show adoption status` on vc(ap7522-4315c) should be as this:

```

ap7522-04315C> show adoption status
Adoption Mode: CONTROLLER
--------------------------------------------------------------------------------------------------------------------------------
DEVICE-NAME       VERSION         CFG-STAT         MSGS ADOPTED-BY        LAST-ADOPTION                  UPTIME     IPv4-ADDRESS
--------------------------------------------------------------------------------------------------------------------------------
ap7522-045320     5.9.8.4-002R    configured       No   ap7522-04315C       0 days 00:18:52     0 days 00:21:01    192.168.9.144
ap7522-A2DA54     5.9.8.4-002R    configured       No   ap7522-04315C       0 days 00:30:23     0 days 15:23:04    192.168.9.141
---------------------------------------------------------------------------------------------------------------------------------

```

 

but it's weird, the actrual result is:

 

```

ap7522-04315C> show adoption status
Adoption Mode: CONTROLLER
--------------------------------------------------------------------------------------------------------------------------------
DEVICE-NAME       VERSION         CFG-STAT         MSGS ADOPTED-BY        LAST-ADOPTION                  UPTIME     IPv4-ADDRESS
--------------------------------------------------------------------------------------------------------------------------------
ap7522-045320     5.9.8.4-002R    configured       No   ap7522-04315C       0 days 00:18:52     0 days 00:21:01    192.168.9.140
ap7522-A2DA54     5.9.8.4-002R    configured       No   ap7522-04315C       0 days 00:30:23     0 days 15:23:04    192.168.9.141
---------------------------------------------------------------------------------------------------------------------------------

```

that make me confused.

by the way, that will be convenient if the forum support markdown.

ckelly
Extreme Employee

Here’s what I see from your postings:

This AP has an override IP address for .144

ap7522 74-67-F7-04-53-20
use profile default-ap7522
use rf-domain default
hostname ap7522-045320
interface vlan9
ip address 192.168.9.144/24

 

You say that the the VC’s IP is 192.168.9.140, but I don’t see any of the APs assigned a .140 address  anywhere in the posted config.

 

And then you say, “but when `show adoption status` on vc”, it outputs information for AP

ap7522-04315C

which has a static IP address of .143 in the posted config.

 

So I’m having a hard time determining which MAC address is supposed to be the VC in this setup.

RobertZ
Extreme Employee

Seams that is the VC, you have configured with the below: 
 

 virtual-controller auto
virtual-controller management-interface ip address 192.168.9.140/24
virtual-controller management-interface vlan 9

 

RobertZ
Extreme Employee

You can also do that with one cli command: 
directly on device “ service clear crash-info “
from wlc “service clear crash-info on <device_name> “

zlinuxboy
Contributor

@arichter 

here are the relative cli result on vc:

51232e1009b840039e53f3cabe23e914_65258746-0d3a-4396-ba8a-66a043b7cb20.jpg

 

Yes, you are right, after delete the crashinfo, the hostname’s suffix * disappear.

GTM-P2G8KFN