Showing results for 
Search instead for 
Did you mean: 

Download EXOS - new rules

Download EXOS - new rules

Valued Contributor
Hello, all!

For now eSupport web-site is unavaliable.
Redirecting to
In past I was able to download EXOS by putting S/N of switch, for now I have to open a case every time when I want to download EXOS?


Thank you!

Same issue to me !

Allow Pop-ups for and using IE or Chrome it works. Firefox (my prefered / default) Browser does not work.


Valued Contributor III
Hi Jeremy,
I was able to connect to your account in the portal and tried to download the two versions you mentioned here. Once I added the exceptions in Chrome's popup blocker, they both downloaded for me without issue after specifying the same serial number you used (13***-***94). I'm not aware of any issues on the portal, but can't rule that out as a possibility.

Could you please try again and let me know how it goes?

summitX- I receive that message specifically on Firefox only, have had different people from the office try it as well. In other browsers nothing happens.

Sorry if this should be in a different help section but it was the closest instance I could find to my issue.

edit - I do get the same issue with other .xos files as well.
summitX- just had the same error.

Valued Contributor III
That might be a different issue, Jeremy. Can you let me know what file you were attempting to download?

New Contributor II
Hi Ryan,

I can't download an EXOS successfully. I can see the info what I want in 'download history' after I click 'Download File' but the file was not downloaded to my computer. Would you let me know how I can get one file downloaded successfully?